Jump to content

Recommended Posts

Hey! Hoping someone might be able to help! I’ve changed my fuel filter tonight (2008 GU Patrol 3.0L Diesel) and now it won’t start! 
ive made sure all the hoses are fitted properly and tightened well. The issues seems to be that it’s not priming. I’ve tried priming whilst cranking simultaneously. My brother in law who is a diesel mechanic (4 hrs away via FaceTime) suggested removing the input hose between the primer bulb and the fuel filter and priming to see diesel coming out the hose but nothing!! I’ve tried pressurizing the tank with the air compressor. Still nothing. Despite priming the bulb about 200 times I’m not getting any fuel up the hose from the tank and into the priming bulb and for the life of me I can’t work out why!! Was running fine before I changed the filter. The bulb is pumping it’s not staying flat or anything like that. Got just over 1/2 a tank. Initially had 1/4 so added another 20 or so litres thinking the issue was not enough in the tank. Any recommendations would be very helpful. Pulling my hair out! Cheers. 

Link to post
Share on other sites

G'day,

Well you probably already know the answer, you need to replace the priming bulb. The other way to get going is to pre-fill fuel filter and then hope it (engine) starts and finishes the priming itself. The additional way could be to try one of those 12V electric fuel transfer pumps to get the fuel up.

To check that priming bulb is good you could fill a jar with fuel and see if the any action happens.

Regards

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...