Jump to content
Bizz

Front right wheel knock/grinding noise

Recommended Posts

So I thought the wheel bearings where on there way out and purchased a new set (both sides) pulled the offending side apart cleaned it all up and guess what, they have already been done by the previous bloke. (I've had her for 18 months) so now I'm stumped to what is causing the noise, it only happens when I turn left while under power, could it be the suspension? The front shocks have been replaced but the rest all look original as they are all black.

Share this post


Link to post
Share on other sites

I'd check for loose panhard rod/bushes I have a what appears a grinding noise when turning left and slowing down/coming to a stop at the same time. At first I was concerned but now after checking everything and not finding a thing I am waiting for the failure to happen.

Cheers

Share this post


Link to post
Share on other sites

I had both my front wheel bearings replaced on my gu after some strange noises as you describe. I also noticed that my free wheeling hubs were getting really really hot, to the extent that you couldn't touch them after a medium drive, and the grease was liqifying..

New bearings in and she is all sweet again. Mine us a GU though so may or may not be the same...

Good luck!

Sent from my Galaxy Nexus using Tapatalk 2

Share this post


Link to post
Share on other sites

Could be your king bearings.

i.e the front wheel wobbles

Jack the truck up.

Grab the top and bottom of the front tyre, and try wobbling it back and forwards - If theres more then a couple mm of movment. Then the king bearings are shot.\

Personaly I would replace the king and wheel bearings, seals etc.

nEWBIE YOU PROBALLY OVER TIGHTENED THE BEARINGS.

Share this post


Link to post
Share on other sites

So last weekend After having a wheel alignment and balance I've retightened the wheel bearing with a torque wrench to spec and 90% of the vibration has gone so I'm happy with that for now till the finances allow more expense.

Share this post


Link to post
Share on other sites

Grinding noise and hot hubs would indicate that that hub is trying to engage as your driving or its not fully retracting into itself when put in free.

My drivers side started to make the same sound and was super hot replaced the hub with a spare and presto all good now :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...