Jump to content
Sign in to follow this  
Kranwa

2000 ZD30 clutch issue.

Recommended Posts

Hi guys. Got a strange one here. Have owned the truck just over 3 months and slowly overt the last month or a little more it had been getting really difficult to get into 1st 2nd and reverse. At first I thought it was maybe syncros but it was 3 of the gears all around the same time. Also I found a receipt in the glove box for a full gearbox rebuild and clutch replacement 2 years ago less than 30,000ks ago. I've bleed the clutch a few times now and while the clutch feels a lot better the problem has not improved. It feels like the pressure plate maybe cos when I stop and leave it in gear I can feel the truck want to crawl forward like the clutch hasn't fully disengaged. It looks as though I've got full movement from the slave cylinder but I never really checked it out before I had the problem. Surely the clutch isn't stuffed so soon after being replaced.

Share this post


Link to post
Share on other sites

So where on the pedal position do you feel full clutch engagement. Is it early at low position? You need to check if the lever linkage isn't binding and also make sure the bell housing isn't full of mud/crud which doesn't help.

Normaly you'll get the clutch slipping as it wears out and take up point moves up on the pedal travel.

This sound like something is inhibiting full clutch travel or it could be that you aren't getting the full clutch travel due to hydraulic failure.

Cheers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×