Jump to content

Changed Fuel Filter


yayansid
 Share

Recommended Posts

Hey! Hoping someone might be able to help! I’ve changed my fuel filter tonight (2008 GU Patrol 3.0L Diesel) and now it won’t start! 
ive made sure all the hoses are fitted properly and tightened well. The issues seems to be that it’s not priming. I’ve tried priming whilst cranking simultaneously. My brother in law who is a diesel mechanic (4 hrs away via FaceTime) suggested removing the input hose between the primer bulb and the fuel filter and priming to see diesel coming out the hose but nothing!! I’ve tried pressurizing the tank with the air compressor. Still nothing. Despite priming the bulb about 200 times I’m not getting any fuel up the hose from the tank and into the priming bulb and for the life of me I can’t work out why!! Was running fine before I changed the filter. The bulb is pumping it’s not staying flat or anything like that. Got just over 1/2 a tank. Initially had 1/4 so added another 20 or so litres thinking the issue was not enough in the tank. Any recommendations would be very helpful. Pulling my hair out! Cheers. 

Link to comment
Share on other sites

G'day,

Well you probably already know the answer, you need to replace the priming bulb. The other way to get going is to pre-fill fuel filter and then hope it (engine) starts and finishes the priming itself. The additional way could be to try one of those 12V electric fuel transfer pumps to get the fuel up.

To check that priming bulb is good you could fill a jar with fuel and see if the any action happens.

Regards

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...