Jump to content

What's been happening?


Recommended Posts

Thought I'd start another thread for what everyone is doing with their trucks.

This weekend I've been fixing my rear bumper needed extra bracing cause of spare tyre carrier, so I'm using angle to beef it up. I also finished paint the lower section of the truck. It's now a white with a black bottom. It's good to have her looking good again. Then I got the horn and blinkers working. Not long now...

post-52-133638250099_thumb.jpg

post-52-133638253321_thumb.jpg

Sorry about the photos, I only remember to take them when the light is nearly gone.

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

Got a new 4wd action mag today called OFF-ROAD Addiction issue 2 and right near the front of the mag is an mq patrol, with external roll cage and 40in tyres. looks tops. it also says that there will be a full feature in an upcoming mag.

Link to comment
Share on other sites

Ordered a new compressor wheel and housing for my turbo to continue testing to find a suitable replacement turbocharger.

Went for a 4by last night - Awesome fun as it was nice and wet :)

Did a heap of wiring a few weeks back and installed an LED lightbar and also my ARB under bonnet compressor.

Link to comment
Share on other sites

I finally got to drive the truck on the road again, just drove it about 10 km and now it's back at home. Now I can get to it on week nights. Jayden, 3yr old son, hates it when I go play on my truck after work.

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

Changed the front diff gasket (old one leaked a bit) and the diff oil. Gears look really in really good condition. And ordered my new oil pressure sender unit finally. The old one was a b€tch to get off.

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

Hey mk tank, the sender unit is the correct one. The oil pressure sits on about half after initial start up when it spikes to full. The only problem was the wires are the wrong way around in the connector. So today I pulled it back out and swapped the wires around. Now it's perfect.

Also started making mudflaps for the rear, if it wasn't for my 3yr old son I would have finished the front too. We had fun together anyway.

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

  • 1 month later...

Been installing the new turbo to the mq over the last few weeks, using a toyota ct20 turbo so had to change everything, so far ive made the turbo flange adapter, adapted the oil and water lines to fit and now in the final stages of buildig the exhaust, built the 3" dump pipe last night and picked up the last of the mandrel bends and straight piece to finish the exhaust, if im not not ill bring over my build thread and update it this weekend

Link to comment
Share on other sites

Well turbo is all hooked up, dump pipe and exhaust finished, all oil and water lines attatched so cranked the engine over a few times to get some oil into the turbo then Gave it a glow, moment of truth, patrol roared to life whistling its head off, gave it a few mins to warm up then gave it a rev, to my surprise 10psi shot up on the boost gauge just off a free rev, hold the revs up a bit and it climed to 14psi, now i cant wait to get on the road and take it for a drive

Link to comment
Share on other sites

Birthday on the w'kend and spent about $1500 on a winchbar, sidesteps (for my boy), & a rear wheel carrier. Feeling poor now, although the wife did buy me this new tablet, very happy with it. The funny part is that the truck could've been registered this week if I didn't buy them. Soon though.

Sent from my ASUS Transformer Pad TF300T using Tapatalk 2

Link to comment
Share on other sites

  • 4 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...