Jump to content

welshy01

Members
  • Content Count

    3
  • Joined

  • Last visited

  1. HI MEMBERS , HAS ANY ONE GOT A EXPLODED VIEW OF THE VACUUM LINES, MAY HAVE MIXED THEM UP AND BE CAUSING ME TO HAVE NO FULL POWER IN MY GRAND SON NAVARA 2004 UTE REBUILT THE MOTOR FOR BACK TO NEW , NEW HEAD ,INJECTOR PUMP AND INJECTORS . AND HAS NO POWER IN THE LAST TWO GEARS , VERY DOUGHY , COULD I HAVE MISSED ON THE TIMING SET THE PUMP UP WITH DRILL BIT , SO IT SHOULD BE OK , ALL THE TIMING MARKS OK IF I WAS OUT ONE TOOTH ON THE CAMS WOULD THIS BE THE PROBLEM , DONT WANT TO PULL IT DOWN TO FIND THAT IT IS NOT THE PROBLEM MAP IS OK , NO FAULTS ON THE ECU , WHERE DO I LOOK , NEED EXPERT HELP GUYS , RIPPING MY BLOODY HAIR OUT TRYING TO WORK IT OUT MY SELF HAS ANY GOT A LINK TO DOWN LOAD THE FULL WORK SHOP MANUAL RE ENGINE AND TRANNY CHEERS , WELSHY01
  2. HI MEMBERS , FULLY REBUILT ZD30 NAVARA 2004 , NEW INJECTOR PUMP AND INJECTORS BRAND NEW HEAD , GOT IT UP AND RUNNING but NO FULL POWER IN 4TH AND 5TH , STUGGLES TO GET UP TO 95 CLICKS WHAT HAVE I DONE WRONG HAD THE MAP CHECKED NO FAULTS NEW TURBO, , NO ENGINE LIGHT , COULD HAVE THE VACUAM LINES ON WRONG WITH THE VNT , NEED HELP GUYS , SHOULD GO LIKE THE CRAPPERS WITH A NEW MOTOR , SHOULD I LOOK AT TIMING ,(SURE ITS RIGHT ), SOUNDS LIKE IT IS NOT ADVANCING IN THE PUMP ? NEED URGENT HELP JUYS , CHEERS WELSHY01
  3. hi juys , i have a 2001 nissan patrol 4.2 turbo diesel , 60000 on the clock and still going very strong love it with a passion / i have a qusstion to ask , my grand son has had trouble with his zd30 navara gear bos , sticking in 3 rd gear , guess what , pop has to try and fix it for him ,having never worked on a navara , how do i remove the gear box with out any trouble , my patrol not a problem but the navara not sure can i get some help please ,as i have a car hoist and all the tools , what i am worried about it the two top bell housing bolts many thanks guys need help
×
×
  • Create New...