Jump to content

ZD30 loss of power.


Recommended Posts

Ive got a 2000 gu ZD30. Been doing NADS. Have egr block, dawes and needle valve, pyro and boost gauge. I've been playing a lot with it so I'll list the events in chronological order.

Firstly the engine light kept coming on and/or going into limp mode. No NADS fitted yet. Mostly on highway. I replaced MAF sensor with a cheap ebay one. (Mistake). Seemed to fix the problem but now blowing black smoke. Sometimes going into limp mode. But much better.

Next step was fitting gauges. Boost and pyro. Then fitted dawes and needle valves. Set up according to the page I found on this forum. Stopped the over boosting and limp mode. Still blowing smoke.

I figured it might be the cheap maf sensor. Fitted egr block. Everything else was ok.. so i thought.

Went skiing/camping with the missus and a mate, driving down the highway starting limp mode again, then engine light. Kept switching off engine and restarting to reset engine light. Struggled all weekend but got home. Nearly got divorced cos the air con hasn't worked since I bought the truck 8 months ago. Lol. So booked truck in to auto elec to get that sorted.

He had it all pulled apart and diagnosed but I needed it back cos I travel for work. So he put enough back together so i could Have it for a week. I noticed a lack of power and exhaust Temps getting quite high. Some hills I ended up at 60ks an hour which I've never had to do. Thought it was strange. But it was late at night and needed to get to where I was going. The road I drive to work on is horrible and bumpy. I Even had to get the windscreen replaced cos a stone chip cracked the whole thing from the road.

I kept having trouble with engine light and sub tank light coming on. Figured out the stupid battery terminals were falling off the battery from all the bouncing. I temporarily fixed it to get me home till the auto elec can replace the useless terminals that were on it when I got it.

That fixed the sub tank light and I thought it maybe had something to do with the problems I had before I fit the NADs.760 bucks later the air con works. I needed a new condenser. Still struggling for power.

So I put the old MAF sensor back in this week and no more smoke and no limp mode and no engine light. But still no power. I've played with the needle and dawes valve for the turbo but no change. I'm now struggling to get to 120kph. It used to be pretty easy.

Serviced and new air filter 2000ks ago. I do about 3000ks a month just for work. I've blown a gasket on the egr pipe after putting in the block. Just took the block out and test drove to prove it wasn't because of that. Still no difference. Egr block back in. I noticed today though that radiator cap was leaking a bit. I topped up coolant and fixed radiator cap. Not sure if that could have anything to do with power though.

So now I'm stuck. No limp mode. Battery terminals fixed. Not getting hot. Not blowing smoke. Air con is great lol. But still no bloody power. 4 hours on the highway twice a week is bad enough with out having to deal with this crap the whole time.

The truck is for sale cos I'm changing jobs and moving and traveling so many ks in the patrol is not good. But I can't sell it if it's not up to scratch. I can't leave other people with this problem. Anyone got any ideas. I need to get rid of it as soon as I can. Or at the very least get some power back so I'm not ready to kill someone when I get home. Any help and suggestions would be greatly appreciated.

Thanks guys

Link to comment
Share on other sites

Mate, it is all guess work but what boost pressure do you get up to?  It is fairly common on early ZD30 vintage that they have vacuum leak in either hosees or the vac cylinder/reservoir so turbo vanes will not open fully. You can check it easily by starting the engine and at idle see if turbo actuator lifts up against the stop bolt and stays there not fluctuating up/down. If it doesn't bypass all the vac reservoir lines and connect a hose directly to the actuator.



Link to comment
Share on other sites

  • 2 weeks later...
  • 5 years later...


I have a Nissan Patrol 3.0 ltr turbo diesel 2008 ,around 4months ago well driving it started losing power have had it in Nissan for about 3 months and the menc cant seem to find the problem have just picked it up and got it home , it is worse then it was can drive it slow as soon as you go to 2000rpms stalls and you have to turn key off and back on to start the car again ????Nissan had it up on host and they could get it to120 mph fine didn't stall at all as soon as they started pulling hand break and putting it under load it dies ?the only code coming up they said is large fuel leak , have been through the whole car replaced all fuel lines and still made no difference ? any help at all would be great at this point .have had itfor 18 months 

Link to comment
Share on other sites

  • 4 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...